python 3.4.2 버전입니다. twisted를 사용하고싶은데 ... 호환이안되나요??


python 3.4.2 버전을 사용하는데요 twisted를 사용하려고 합니다. alt text

이와 같은 에러가나는데 ... 호환이안되는건가요 ? 다운버전을 하면 되는걸까요?? 도와주세요!!

  • 2016년 02월 10일에 작성됨

  • 이미지가 짤려서 정확한 에러 메시지를 볼 수가 없네요... 뭘 하는중에 에러가 나는건지도 설명이 필요합니다.    정두식   2016.2.10 16:33     
조회수 233


1 답변


좋아요
0
싫어요
채택취소하기

아직은 python3버전을 지원하지 않는다고 합니다. python3로 포팅중인것 같긴 하네요. https://twistedmatrix.com/trac/wiki/Plan/Python3

전체 패키지는 아직 완성은 안됬고 일부 모듈별로 완성된것 같긴한데... 꼭 twisted를 써야 한다면 그냥 2.7버전을 쓰는게 좋을것 같습니다.

  • 2016년 02월 10일에 작성됨
    루비와 파이썬을 좋아합니다. 새로운 언어를 배우는것도 좋아해요. 모바일 게임도 조금 만들어 봤습니다.

로그인이 필요한 기능입니다.

Hashcode는 개발자들을 위한 무료 QnA사이트 입니다. 작성한 답변에 다른 개발자들이 댓글을 작성하거나 좋아요/싫어요를 할 수 있기 때문에 계정을 필요로 합니다.
► 로그인
► 계정만들기
Close