이클립스 프로젝트 인텔리제이로 변경중에 .classpath 수정을 어떻게 해야하는지 모르겠습니다.


Module pamis: invalid item 'org.eclipse.jst.j2ee.internal.module.container' in the dependencies list Module pamis: invalid item 'org.eclipse.jst.j2ee.internal.web.container' in the dependencies list Module pamis: invalid item 'org.eclipse.m2e.MAVEN2_CLASSPATH_CONTAINER' in the dependencies list 이와같은 에러가 발생합니다.

구글링을 해보니 .classpath에 아래를 수정해야 하는 것 같은데

<classpathentry exported="true" kind="con" path="org.eclipse.jst.j2ee.internal.module.container"/>
<classpathentry exported="true" kind="con" path="org.eclipse.jst.j2ee.internal.web.container"/>
<classpathentry exported="true" kind="con" path="org.eclipse.m2e.MAVEN2_CLASSPATH_CONTAINER"/>
<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5">

1.맨 밑에 JRE는 컴파일러를 1.5로 수정해서 고쳤는데,

jdk 1.6을 사용하는데 jre 컴파일러를 J2EE(1.5)를 사용해도 되는 건가요?

2.클래스패스엔트리는 어떻게 수정을 해야하나요?


  • 인텔리제이의 환경설정에서 Maven 관련 설정을 확인해 보시는 것이 좋을 것 같습니다.    Hyunbeom Heo   2016.5.15 17:34     
  • 감사합니다 ^^     TaeHwan Park   2016.5.26 11:23     
조회수 368


로그인이 필요한 기능입니다.

Hashcode는 개발자들을 위한 무료 QnA사이트 입니다. 작성한 답변에 다른 개발자들이 댓글을 작성하거나 좋아요/싫어요를 할 수 있기 때문에 계정을 필요로 합니다.
► 로그인
► 계정만들기
Close