안드로이드 앱 force update


안드로이드 앱을 강제 업데이트 하는 부분이 구현 되어있지 않은 앱이 있습니다.

1.0.0 < 강제 업데이트 체크로직이 없음

1.1.0 < 앱이 시작될 때, 버전정보가 있는 파일을 CDN 에서 읽어와 강제 업데이트 여부를 체크

이런 상황일 때, 1.0.0 버전을 가지고 있는 사용자들을 강제 업데이트 할 수 있는 방법은 없을까요?

가령 구글 개발자콘솔 같은데에, 앱 을 올리면서 강제 업데이트 해야하는 버전이라고 설정할 수 있다던지...

방법이 있는지 답변좀 부탁드리겠습니다.

  • 2016년 05월 09일에 작성됨

  • 백엔드 쪽에서 따로 푸쉬를 보내서 메세지를 보여주거나 업데이트 체크 로직이 없으면 방법이 없지 않나요?? 저도 궁금했던 부분이라 댓글 달아봅니다 :)    myoung   2016.5.9 20:43     
조회수 533


1 답변


좋아요
3
싫어요
채택취소하기

안드로이드 앱을 강제로 업데이트 시키는 방법은 존재하지 않습니다. 구글 개발자 콘솔에도 그런 기능은 제공되지 않고요. 사용자가 해당 앱에 대해서 자동 업데이트를 활성화 한 경우에는 백그라운드로 업데이트가 되지만 그렇지 않은 경우는 사용자가 플레이스토어에서 직접 업데이트를 해야합니다. (참고로 자동 업데이트가 활성화 된 경우에도 앱에 새로운 권한 그룹이 추가되면 자동 업데이트가 되지 않습니다.)

푸시를 보내거나 앱을 실행 했을 때, 새로운 버전에 대한 업데이트 안내 후 플레이스토어로 이동시키는게 적절한 대안일 것 같습니다. 이 방법도 사전에 서버에서 제어할 수 있도록 작업되어 있어야 합니다.


로그인이 필요한 기능입니다.

Hashcode는 개발자들을 위한 무료 QnA사이트 입니다. 작성한 답변에 다른 개발자들이 댓글을 작성하거나 좋아요/싫어요를 할 수 있기 때문에 계정을 필요로 합니다.
► 로그인
► 계정만들기
Close