realm 적용하기


안녕하세요~ 안드로이드 공부를 하는 중입니다~

realm을 알게되어서 적용을 해보고 있는데요..

처음부터 막혀서 이렇게 질문 드려요 ㅠㅠ

아 먼저 제가 컴퓨터 공학을 전공으로 한 것은 아니고, 그렇다고 안드로이드나 자바에 대해서 빡! 하고 공부를 한것이 아니라서 답답하실수도 있으니.. 이해 부탁드립니다.ㅠㅠ (gradle이니 프로가드니 그런것에 대해서 잘 모릅니다.. 아니 사실 완전히 모릅니다.... ㅠ)

https://realm.io/kr/docs/java/latest/#section-2

안에 있는 문서를 보고 따라하는 중인데요

설치하기 의 단계1에서 프로젝트 수준의 build.gradle 파일에 추가하라는 것을 classpath "io.realm:realm-gradle-plugin:"을 추가하고

app 수준의 gradle 파일의 dependencies안에 apply plugin: 'realm-android'를 추가하였는데 (사실 app수준 안에 dependencies안에 하는 것이 맞는지 모르겠습니다...)

이후에 sync project를 해보면 에러가 나는데 왜 그럴까요....

 프로젝트 수준
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.1.0'
        classpath "io.realm:realm-gradle-plugin:"
    }

   app 수준

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.4.0'
    compile 'com.android.support:design:23.4.0'
    apply plugin: 'realm-android'
}


이렇게 하였고

이미지

오류는 이러한 오류가 나왔습니다....

  • 2016년 06월 22일에 수정됨
    모바일 데이터 베이스를 만드는 yet another nit picker.
  • 2016년 06월 22일에 작성됨

조회수 566


1 답변


좋아요
5
싫어요
채택취소하기

안녕하세요. Realm의 김용욱입니다.

지금 저희 사이트를 개편하면서 버전 표기가 문제가 생겼네요. 그래서 문제를 겪으시는 것입니다. 그 부분에 대해 죄송합니다.

classpath "io.realm:realm-gradle-plugin:"classpath "io.realm:realm-gradle-plugin:1.0.1"로 바꾸어서 입력해보세요.

  • 2016년 06월 22일에 작성됨
    모바일 데이터 베이스를 만드는 yet another nit picker.

  • 으엇 그런 간단한 ... 문제가.... ㅠㅠㅠㅠ 감사합니다 ㅠㅠ 버전업이 될 때마다 realm 사이트에 있는 버전으로 바꿔주면서 적용시키면 되는 것인가요?    TuTanKhamen   2016.6.22 16:55     
  • 맞아요.    Leonardo YongUk Kim   2016.6.23 00:50     

로그인이 필요한 기능입니다.

Hashcode는 개발자들을 위한 무료 QnA사이트 입니다. 작성한 답변에 다른 개발자들이 댓글을 작성하거나 좋아요/싫어요를 할 수 있기 때문에 계정을 필요로 합니다.
► 로그인
► 계정만들기
Close