postgresql 에서 postgis, django를 쓸 때 인터널 에러가 발생합니다. 라이브러리를 불러올 수 없다는 에러 어떻게 해결할까요?


django에서 python3 manage.py migrate 를 실행하니

django.db.utils.InternalError: could not load library "/usr/lib/postgresql/9.5/lib/postgis-2.2.so": /usr/lib/liblwgeom-2.2.so.5: undefined symbol: GEOSClipByRect

이런 에러가 발생합니다.

제가 나름 열심히 능력껏 구글링을 해보니 이런 문제가 발생한 경우 관련해서 글이 한두개 나왔는데요,

https://trac.osgeo.org/postgis/ticket/3423

에서 얼핏 보니 postgresql 버전을 지금 쓰고 있는 우분투 리눅스에서 apt-get install 하면 나오는 9.5 대의

최신버전 말고 9.4 대의 버전을 쓰면 되는 것 같더라구요

그래서 혹시 다른 해결책이 없다면 9.4 버전을 다운로드 하는 방법을 알 수 있을까요? 궁금합니다.

  • 2016년 07월 19일에 작성됨

조회수 159


1 답변


좋아요
1
싫어요
채택취소하기

https://www.postgresql.org/download/linux/ubuntu/

공식 홈페이지에 나와있기로는

apt-get install postgresql-9.4

이렇게 하면 된다는것 같네요

위에 설치방법이 안되면 밑에 apt repository 에서

버전에 맞는 명령어를 넣으시면 될것같습니다

  • 2016년 07월 19일에 작성됨
    웹을 좋아함

  • 좋은 답변으로 해결할 수 있었습니다. 감사합니다.    홍민구   2016.7.20 02:34     

로그인이 필요한 기능입니다.

Hashcode는 개발자들을 위한 무료 QnA사이트 입니다. 작성한 답변에 다른 개발자들이 댓글을 작성하거나 좋아요/싫어요를 할 수 있기 때문에 계정을 필요로 합니다.
► 로그인
► 계정만들기
Close