아마존 리눅스 AMI에 ruby와 rails 버전문제(?)


아마존 리눅스 AMI를 이용해 ruby와 rails를 공부하고 있는 학생입니다. 기본적으로 AMI에는 루비 2.0.0이 깔려있습니다. 그래서 최신버전으로 다시 설치했습니다. (ruby는 2.3.1, rails는 5.0.0.1) 헌데 어찌된 영문인지 서버를 껐다 키면 ruby는 2.0.0으로 돼 있고 rails는 아예 삭제됩니다. 희한한 것은 rails 4.0.x를 깔면 서버를 껐다 켜도 남아 있다는 것입니다.

  • 2016년 09월 09일에 작성됨

조회수 113


1 답변


rbenv나 rvm같은 도구 사용을 권장합니다.

rbenv, rvm을 이용하면 여러 버전의 루비를 설치할수있고 원할때마다 버전을 바꿔서 사용할수 있습니다.

지금같은 경우엔 꼬여서 어떻게 손을대기가 애매한 상황같네요

rbenv, rvm중에선 rbenv를 추천드립니다. rails를 만든 DHH도 rbenv를 사용한다고 합니다

rbenv 설치

https://github.com/rbenv/rbenv

rvm 설치

https://rvm.io/

  • 2016년 09월 09일에 작성됨
    웹을 좋아함

  • 감사합니다~    rhinoPHS   2016.9.10 07:34     

로그인이 필요한 기능입니다.

Hashcode는 개발자들을 위한 무료 QnA사이트 입니다. 작성한 답변에 다른 개발자들이 댓글을 작성하거나 좋아요/싫어요를 할 수 있기 때문에 계정을 필요로 합니다.
► 로그인
► 계정만들기
Close