파이참에서 설치시 인터프리터 설정할 때 파이썬 버전 질문드립니다.


안녕하세요. 파이참을 이번에 새로 설치하고있는데 설치 중간에 인터프리터 설정하는게 있지 않습니까?

그때 제가 선택할 수 있는 파이썬 버전이 2.6과 2.7 밖에 없더라구요. (라이브러리에서 파이썬 폴더 안에도 2.6과 2.7버전만 있습니다. 이게 아나콘다 설치할 때 깔린건지 제가 예전에 따로 설치해놓은 것인지는 잘 모르겠네요.)

터미널에서 파이썬 버전을 확인했을 때는 3.6으로 뜨는데 왜 파이참설치 할 때는 왜 저 두개 밖에 안뜨는지 궁금합니다.

파이썬 2와 파이썬3은 호환성이 없다고 들어서 이왕 설치하는김에 최신버전인 3으로 설치하고 싶은데 인터프리터에서 선택할 수 있는게 2버전 밖에 없어서 당황스럽네요. ㅠㅠ

이 문제를 어떻게 해결해야될까요? 아나콘다를 재설치해야되나요? ㅠㅠ

  • 2017년 08월 07일에 작성됨

조회수 196


1 답변


맥에는 파이썬이 기본으로 설치되어있습니다 (최신 os가 2.7로 알고있어요.)

파이썬 공식홈페이지가서 다운로드 받아 설치하셨다면,

파이참에서 Preference-> Project Interpreter 검색하셔서 새로 설치한 파이썬 경로를 잡아주시면 됩니다.

경로는 이렇게 예상되네요 : /Library/Frameworks/Python.framwork/Versions/3.6/bin/python3.6

  • 2017년 08월 10일에 작성됨
    Software Developer

로그인이 필요한 기능입니다.

Hashcode는 개발자들을 위한 무료 QnA사이트 입니다. 작성한 답변에 다른 개발자들이 댓글을 작성하거나 좋아요/싫어요를 할 수 있기 때문에 계정을 필요로 합니다.
► 로그인
► 계정만들기
Close