ruby gem에서 버전을 지정하는 플래그

command line에서 gem을 쓸 때, 특정 버전을 지정하려면 어떤 플래그를 써야 할까요?

1답변

  • 좋아요

    0

    싫어요
    채택취소하기

    기본적으로는 -v 또는 --version 플래그를 씁니다.

    $ gem install fog -v 1.8
    $ gem install fog --version 1.8
    

    추가로는 >=~>같은 비교도 할수 있습니다.

    $ gem install rails -v '~> 0.14.0'
    

    가장 최신의 gem을 설치하려면

    $ gem install rails:0.14.4 rubyzip:'< 1'
    …
    Successfully installed rails-0.14.4
    Successfully installed rubyzip-0.9.9
    

ᕕ( ᐛ )ᕗ
로그인이 필요합니다

작성한 답변에 다른 개발자들이 댓글을 작성하거나 댓글에 좋아요/싫어요를 할 수 있기 때문에 계정을 필요로 합니다.