파이썬 같은 라이브러리 다른 버전으로 중복 사용할수있나요?

조회수 60회

파이썬에 transformers 를 사용하고있는데 학습되어있는걸 불러오다보니 구버젼라이브러리랑 호환이 되서 하나의 파이썬에서 3.01 버전이랑 4.10버전 이 두개를 같이쓰고싶은데 방법이있을까요?

1 답변

  • 좋아요

    2

    싫어요
    채택 취소하기

    이런 것 때문에 가상환경을 사용해야 합니다.

    바닐라 파이썬이라면 venv 또는 virtualenv 로 가상환경을 생성하고, 생성한 가상환경을 activate 하고 그 가상환경 안에서 라이브러리를 설치하고, 실행하시고요.

    또 다른 가상환경을 만들고 activate 하여 그 가상환경 안에소 다른 버전의 라이브러리를 설치하여 실행하고요.

    Anaconda 환경에서 파이썬을 사용한다면 venv 대신에 conda create 명령으로 가상환경 생성하고요.

    • venv 로 해결했습니다 감사합니다 wql7654 2021.9.3 08:24

답변을 하려면 로그인이 필요합니다.

Hashcode는 개발자들을 위한 무료 QnA 사이트입니다. 계정을 생성하셔야만 답변을 작성하실 수 있습니다.

(ಠ_ಠ)
(ಠ‿ಠ)

ᕕ( ᐛ )ᕗ
로그인이 필요합니다

Hashcode는 개발자들을 위한 무료 QnA사이트 입니다. 계정을 생성하셔야만 글을 작성하실 수 있습니다.