키움증권 api를 해보려고 하는데 모듈설치가 안됩니다.

조회수 70회

https://jackerlab.com/kiwoom-api-default-dev-guide-get-data/ 위의 웹페이지를 따라해 보고있는데,

import sys from PyQt5.QtWidgets import * import KiwoomAPI

이런 모듈이 필요한 것 같네요.

그래서 pip로 설치하면 이미 설치되었다고 나오고 conda로 설치하면 packages 찾을수없다고 나옵니다.

실행을 해봐도

모듈을 찾을수 없다는 이야기만 나오네요.

아나콘다에서 어떻게 설치하는지 답변 부탁드립니다.

이미지

이미지

1 답변

  • import KiwoomAPI 코드 때문에 말씀하시는거라면 파이썬에는 KiwoomAPI 라는 공식적인 모듈이 없습니다. 링크 올리신 사이트의 파일구조라는 부분을 보십시오.

    파일 구조
    ㄴKiwoomAPI.py
    ㄴ KiwoomMain.py

    라고 되어있습니다. 파일을 2개 만들어서 쓰는 것입니다. 실행 파일은 KiwoomMain.py 이군요. 링크 주신 사이트를 잘 읽어보시면 KiwoomAPI.py 코드가 적혀있고, KiwoomMain.py 코드가 따로 적혀있습니다. KiwoomAPI.py 파일을 만들어서 KiwoomMain.py 파일에서 불러와서 실행한다는 것 입니다. 아시겠지만 모듈=파일 입니다.(아시겠지만 질문 내용으로 보아 착각하실 수도 있을거 같아 적어둡니다.)

답변을 하려면 로그인이 필요합니다.

Hashcode는 개발자들을 위한 무료 QnA 사이트입니다. 계정을 생성하셔야만 답변을 작성하실 수 있습니다.

(ಠ_ಠ)
(ಠ‿ಠ)

ᕕ( ᐛ )ᕗ
로그인이 필요합니다

Hashcode는 개발자들을 위한 무료 QnA사이트 입니다. 계정을 생성하셔야만 글을 작성하실 수 있습니다.