1 답변

  • 좋아요

    0

    싫어요
    채택 취소하기

    sys 모듈에 해당 기능이 구현되어 있습니다.

    1. sys.version - 인터프리터버전+빌드넘버사용된 컴파일러에 대한 string
    2. sys.version_info - major, minor, micro, release level, serial에 대한 tuple
    3. sys.hexversion - 버전을 담고있는 정수값
    import sys
    
    #사람이 보기 편함
    print "--sys.version--"
    print sys.version
    
    print "\n--sys.version_info--"
    print sys.version_info
    
    print "\n--sys.hexversion--"
    print sys.hexversion
    

    만약에 스크립트가 특정 버전 이상에서만 동작하도록 만들고 싶으신 거면 다음과 같이 쓰세요

    assert sys.version_info >= (2, 5) #2.5이상에서만 동작
    assert sys.version_info >= (3, 5, 0) #3.5.0이상에서만 동작
    

    특정 버전 미달인 경우 AssertionError가 발생합니다.

답변을 하려면 로그인이 필요합니다.

Hashcode는 개발자들을 위한 무료 QnA 사이트입니다. 계정을 생성하셔야만 답변을 작성하실 수 있습니다.

(ಠ_ಠ)
(ಠ‿ಠ)

ᕕ( ᐛ )ᕗ
로그인이 필요합니다

Hashcode는 개발자들을 위한 무료 QnA사이트 입니다. 계정을 생성하셔야만 글을 작성하실 수 있습니다.