쥬피터노트북 실행이 안됩니다;

조회수 74회

제가 장고로 실습하는 중, 아니콘다에 내장돼 있는 파이썬 3.7버전을 삭제하고 3.8로 교체했어요.

그리고 난 후 쥬피터노트북을 열었는데 콘다의 cmd창이 열렸다가 바로 꺼져버립니다..

이게 아나콘다의 파이썬 버전이 달라서 그런건지 ..모르겠습니다.. 이게 아나콘다 내의 파이썬 버전 문제인가요?이미지

  • jupyter 실행을 어떻게 하셨었는지 알 수 있을까요? 명령 프롬프트에서 직접 입력하셨는지. 아니면 navigator에서 직접 실행 하셨는지 등등. Dibrary 2020.3.26 15:38
  • 아 이제 봤어요; 저는 항상 실행을 윈도우 창에서 화면 아래 윈도우 실행 누르고 바로가기를 통해서 열었습니다(설명이 잘 안되네요;;) yubin cho 2020.3.27 02:54
  • 캡쳐 화면을 위에 수정해서 올렸어요 ;; yubin cho 2020.3.27 02:55
  • cmd에서 "jupyter notebook'으로 입력하면 "from . import (constants, error, message, context, ImportError: cannot import name 'constants' from partially initialized module 'zmq.backend.cython' (most likely due to a circular import)" 라는 에러가 나옵니다; yubin cho 2020.3.27 03:00
  • 위에 에러나서, pip uninstall pyzmq 과 pip install pyzmq을 해줬는데요, 여전히 실행이 안되여. yubin cho 2020.3.27 03:03
  • 해결됐습니다! Dibrary님 덕분에 제가 좀 더 찾아보고 pyqt 와 pyqtwebengine도 설치했더니 정상적으로 잘 작동합니다 감사드려요 yubin cho 2020.3.27 03:16
  • 새벽에 엄청 많은 일이 있으셨네요.하하. 다행이에요!. Dibrary 2020.3.27 09:31
  • 네 ~^^ yubin cho 2020.3.27 12:40

답변을 하려면 로그인이 필요합니다.

Hashcode는 개발자들을 위한 무료 QnA 사이트입니다. 계정을 생성하셔야만 답변을 작성하실 수 있습니다.

(ಠ_ಠ)
(ಠ‿ಠ)

ᕕ( ᐛ )ᕗ
로그인이 필요합니다

Hashcode는 개발자들을 위한 무료 QnA사이트 입니다. 계정을 생성하셔야만 글을 작성하실 수 있습니다.